# Resolved dependency tree for py-sdk, pinned so GitHub's dependency graph can see it.
#
# WHY THIS FILE EXISTS: pyproject.toml declares version *ranges*, and the graph records
# those as versionInfo: null -- Dependabot cannot match an advisory against "no version",
# so py-sdk had zero vulnerability detection. Every other ecosystem here has a lockfile;
# this is Python's.
#
# RESOLVED FOR PYTHON 3.10, which is NOT the floor. pyproject still declares >=3.9 and CI
# tests both. 3.10 is used here because it is the oldest Python that can install the patched
# releases of two packages in this tree: anyio (4.13+ dropped 3.9; the fixes for
# GHSA-82r6-8w77-94w6 and GHSA-5p39-cfhj-2xmp are in 4.14.2) and pytest (9.x dropped 3.9;
# GHSA-6w46-j5rx-g56g is fixed in 9.0.3). A 3.9 install resolves anyio 4.12.1 and
# pytest 8.4.2 instead, and no release of ours can change that: anyio comes in unpinned
# through httpx, and upstream publishes no patched build for 3.9. Resolving for 3.9 would
# only make this file report advisories that every 3.10+ install already avoids.
# Do NOT regenerate on a newer interpreter than 3.10 without a reason.
#
# NOT the install path. CI still runs `pip install -e ".[dev]"` against the declared
# ranges, so an upstream breaking change still surfaces. This file exists to be scanned.
#
# UNVERIFIED: whether Dependabot will also *update* this file is untested -- it maintains
# lockfiles it resolves from a manifest it installs with, and nothing installs from this
# one. If security-update PRs never appear, regenerate by hand:
#   pip install --dry-run --ignore-installed --python-version 3.10 --only-binary=:all: \
#       --report r.json "httpx>=0.28.1" "typing_extensions>=4.0.0" "pytest>=7.0.0" \
#       "pytest-asyncio>=0.21.0" "pytest-httpx>=0.21.0"
anyio==4.15.1
backports.asyncio.runner==1.2.0
certifi==2026.7.22
exceptiongroup==1.3.1
h11==0.16.0
httpcore==1.0.9
httpx==0.28.1
idna==3.20
iniconfig==2.3.0
packaging==26.3
pluggy==1.6.0
Pygments==2.21.0
pytest-asyncio==1.4.0
pytest-httpx==0.36.2
pytest==9.1.1
tomli==2.4.1
typing_extensions==4.16.0
